Symptoms
When attempting to transfer accounts via WHM's "Transfer or Restore a cPanel Account" feature, the transfer fails with an error similar to:
CONFIG_TEXT: TRANSFER: Account “cpaneluser”: Error while executing “/usr/local/cpanel/scripts/getremotecpmove”. The “/usr/local/cpanel/scripts/getremotecpmove 203.0.113.2 cpaneluser” command (process 302165) reported error number 255 when it ended.: Cpanel::Exception::HTTP::Network/(XID vqs9wf) The system failed to send an <abbr title="Hypertext Transfer Protocol">HTTP</abbr> “GET” request to “https://203.0.113.2:2083/json-api/cpanel?cpanel_jsonapi_module=Fileman&cpanel_jsonapi_func=listfullbackups&cpanel_jsonapi_apiversion=1” because of an error: Could not connect to '203.0.113.2:2083': Connection refused at /usr/local/cpanel/Cpanel/HTTP/Client.pm line 115, <STDIN> line 1. Cpanel::HTTP::Client::request(Cpanel::HTTP::Client=HASH(0x10bfbb0), "GET", "https://203.0.113.2:2083/json-api/cpanel?cpanel_jsonapi_module"
Cause
This issue is often caused by the Firewall blocking cPanel traffic (TCP port 2083) to the other server. It's also possible that the Firewall on the remote server is blocking the connection.
The default CSF installation does not allow TCP outbound connections on port 2083, which is required for this feature to work.
Resolution
Check the TCP_OUT setting for CSF:
CONFIG_TEXT: # grep ^TCP_OUT /etc/csf/csf.conf
TCP_OUT = "20,21,22,25,37,43,53,80,110,113,443,587,873,993,995,2086,2087,2089,2703"Note: If port 2083 is missing from the list, as in the example above, you will need to add the port to allow the connection. Then restart CSF.
After allowing the port in the TCP_OUT list, restart csf.
# csf -r
Note: You may need to check the Firewall settings on both the local and remote server.
Comments
0 comments
Article is closed for comments.