Symptoms
After LiteSpeed releases a new version, the update notification is not visible in the Web Console.
Cause
If it's been multiple days since the update was officially published and announced, the update notification on your server might not be working due to an issue with the files under the following directory: /usr/local/lsws/autoupdate/
Resolution
Regenerate files within the lsws autoupdate directory:
- Log in to the server via SSH as the
rootuser, or use the WHM Terminal. Create a backup of the autoupdate directory:
# cp -rv /usr/local/lsws/autoupdate /root/lsws-autoupdate-backup$(date +.%Y-%b-%d-%H-%M-%S)
Remove the .last file:
# rm /usr/local/lsws/autoupdate/.last
Hard restart LiteSpeed by executing the following commands on the same line but separated by a semicolon:
# /scripts/restartsrv_apache --stop; /scripts/restartsrv_apache --start
If that does not resolve the issue, you may try removing all of the files within the autoupdate directory.
Warning: Be careful not to delete the directory itself:
# rm /usr/local/lsws/autoupdate/*
Again, Restart LiteSpeed:
# /scripts/restartsrv_apache --stop; /scripts/restartsrv_apache --start
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