Symptoms
The CloudLinux Manager in WHM shows an error:
# The received data is wrong. Contact support for resolution. Traceback (most recent call last):
File "/opt/cloudlinux/venv/lib64/python3.11/site-packages/clcommon/lib/cledition.py", line 76, in get_from_jwt
jwt = decode_jwt(token, verify_exp=verify_exp)
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
File "/opt/cloudlinux/venv/lib64/python3.11/site-packages/clcommon/lib/jwt_token.py", line 20, in decode_jwt
jwt_token = decode(token_string, algorithms=['HS256'],
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
File "/opt/cloudlinux/venv/lib64/python3.11/site-packages/jwt/api_jwt.py", line 210, in decode
decoded = self.decode_complete(
^^^^^^^^^^^^^^^^^^^^^
File "/opt/cloudlinux/venv/lib64/python3.11/site-packages/jwt/api_jwt.py", line 162, in decode_complete
self._validate_claims(
File "/opt/cloudlinux/venv/lib64/python3.11/site-packages/jwt/api_jwt.py", line 248, in _validate_claims
self._validate_exp(payload, now, leeway)
File "/opt/cloudlinux/venv/lib64/python3.11/site-packages/jwt/api_jwt.py", line 306, in _validate_exp
raise ExpiredSignatureError("Signature has expired")
jwt.exceptions.ExpiredSignatureError: Signature has expired
Cause
The CloudLinux license data needs to be refreshed on the server.
Resolution
Use the following command to refresh the IP-based license:
# /usr/sbin/clnreg_ks --force
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