Symptoms
When running a cPanel update or accessing MultiPHP Manager in WHM, you receive an error similar to the following. Where X represents the affected PHP version(i.e. ea-php81).
The “ea-phpX” package does not provide an executable binary.
Cause
The error occurs when a PHP module is installed and the package containing the binary for that PHP version is not installed.
Resolution
To Install the missing package.
From the WHM interface.
- Access your cPanel & WHM server as the
rootuser. - Navigate to Home / Software /EasyApache 4 Interface
- Select Customize
- Select PHP Versions on the left menu
- Use the toggle switch to add or remove the version of PHP you want.
- Click on Review on the left menu
- Click on Provision
From the commandline:
Access the server's command line as the root user via SSH using your favorite terminal application or log in to the WHM interface and navigate to Home / Server Configuration / Terminal.
Warning: Please note that "X" must be replaced with the PHP version.
RHEL-based systems
# dnf install ea-phpX -y
Ubuntu systems
# apt install ea-phpX -y
Comments
0 comments
Article is closed for comments.