Symptoms
A website displays a 404 error, and the Apache error log contains entries similar to the following:
CONFIG_TEXT: [Tue May 11 15:44:38.561822 2023] [:error] [pid 20309] [client 0.0.0.0:43002] [client 0.0.0.0] ModSecurity: collection_store: Failed to access DBM file "/var/cpanel/secdatadir/nobody-ip": Permission denied [hostname "domain.tld"] [uri "/wp-login.php"] [unique_id "Y0XHpIRi00JuFfueZ9KdngARAAk"]
Cause
The 404 error occurs when ModSecurity is unable to access the DBM files, or if the files do not exist.
Resolution
- Log in to the server via SSH or WHM's Terminal as the
rootuser Run the following command to create the DBM files and assign their ownership to nobody:
# touch /var/cpanel/secdatadir/nobody-{ip,session,global}.{dir,pag}; chown -v nobody. /var/cpanel/secdatadir/nobody-{ip,session,global}.{dir,pag}
Note: If the DBM files already exist, the above-provided command will not overwrite them.
Comments
0 comments
Article is closed for comments.