Symptoms
When checking your Exim logs you notice the following error:
CONFIG_TEXT: YYYY-MM-DD HH:MM:SS H=([ipaddress]) [ipadress]:port F=user@remotedomain.tld temporarily rejected RCPT user@localdomain.tld: condition check lookup defer
You also see numerous messages similar to the following when checking the maillog:
CONFIG_TEXT: Mon DD HH:MM:SS hostname dovecot: imap(user@localdomain.tld)<977518><QcQotdvup4y+a+Sf>: Error: Mailbox INBOX.Drafts: file_create_locked(/home/username/mail/domain.tld/emailuser/mailboxes/Drafts/dbox-Mails/dovecot-vsize.lock) failed: safe_mkstemp(/home/username/mail/domain.tld/emailuser/mailboxes/Drafts/dbox-Mails/dovecot-vsize.lock) failed: Disk quota exceeded
Cause
The described errors occur when multiple events coincide:
- A cPanel user's account is over quota
- A mail user on that cPanel account receives a message
- Dovecot in the server is sufficiently busy
This causes Dovecot to effectively Denial of Service attack itself, and prevents the mail from being delivered in a timely manner, which in turn results in the Exim notice above.
We've opened an internal case for our development team to investigate this further. For reference, the case number is CPANEL-41988. Follow this article to receive an email notification when a solution is published in the product.
Resolution
There are currently two known workarounds to this behavior.
Restarting Dovecot will provide temporary relief until Dovecot becomes overloaded again.
- Log in to WHM as
root - Navigate to Home / Restart Services / IMAP Server
- Click the Restart button
Increasing the cPanel user's disk quota provides longer-term relief of the behavior, but it will begin again once the user reaches their quota again.
How to increase an account's quota
Comments
1 comment
Update: CPANEL-41988 is solved in the following cPanel & WHM version(s) and newer:
114.0.6
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