Symptoms
Duplicate emails are being received from a mail server, most commonly Gmail
Cause
A recent upstream change from Google where if the SMTP connection is delayed, it will open second connection from a second mail server and resend the email causing duplicate emails to arrive in your inbox.
We've opened an internal case for our development team to investigate this further. For reference, the case number is CPANEL-53893. Follow this article to receive an email notification when a solution is published in the product.
Resolution
Option 1 (Preferred) - Enable Greylisting
- Access the WHM as the
rootuser. - Navigate to Home / Email / Greylisting and toggle Greylisting from OFF to ON.
- Navigate to Home / Service Configuration / Exim Configuration Manage / ACL and locate Do not delay the SMTP connections for hosts in the Greylisting “Common Mail Providers” list and change this from Off to On
- Save your settings.
Navigate to Home / Server Configuration / Terminal and run the following.
# /usr/local/cpanel/scripts/manage_greylisting --update_common_mail_providers
Option 2 (Backup) - Disable Introduce a delay into the SMTP transaction
- Access the WHM as the
rootuser. - Navigate to Home / Service Configuration / Exim Configuration Manager.
- Locate "Introduce a delay into the SMTP transaction for unknown hosts and messages detected as spam.” and change this from “On” to “Off”.
- Save your settings.
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