Symptoms
The following error occurs when connecting to a remote host using the Transfer Tool:
CPANEL_ERROR: The system stopped waiting to connect to “192.0.2.0” on port “22” after 15 seconds.
Failed to establish session and parse security token: 599 Internal Exception (Could not
connect to '192.0.2.0:2087': Connection timed out) at
/usr/local/cpanel/3rdparty/perl/530/lib/perl5/cpanel_lib/cPanel/PublicAPI.pm line 526.
Cause
This can be caused by one of the following reasons:
- A firewall configuration on the remote host is blocking the server
- The SSH port that was used to connect to the remote host is incorrect.
- The source server's hostname is proxied through Cloudflare
Resolution
You can manually verify the remote host is reachable by the server you are transferring to.
- Connect to the remote host server using SSH as the
rootuser. - Verify which port SSH is configured to use:
# sshd -T | grep '^port
- Connect to the destination server using SSH as the
rootuser. Use either netcat or telnet to try and reach the remote host using it's SSH port:
# nc -vz $IP $PORT
# telnet $IP $PORT
If your server does not have netcat or telnet installed, you can also try and connect using SSH directly:
# ssh -p $PORT root@$IP
A "connection timeout" confirms that comminucation is being prevented between the two servers:
CONFIG_TEXT: # nc -vz 192.0.2.0 22
Ncat: Version 7.50 ( https://nmap.org/ncat )
Ncat: Connection timed out.CONFIG_TEXT: # telnet 192.0.2.0 22
Trying 192.0.2.0...
telnet: connect to address 192.0.2.0: Connection timed outConfirm that the firewalls of both servers allow communication on the specified SSH port both inbound and outbound, and try again.
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