Symptoms
You are attempting to send an email from one server to another, but the sender is seeing the error:
CONFIG_TEXT: 451 Temporary local problem.
The following is also seen in the /var/log/exim_rejectlog on the recipient's server:
CONFIG_TEXT: temporarily rejected connection in "connect" ACL: "Host is ratelimited (100/1h max:5)"
Cause
If you are seeing the error "451 Temporary local problem," it is most likely that the sender is blocked due to being rate-limited.
Resolution
Note: If email being sent from your server is failing to some recipients with this error, the issue will need to be resolved by that recipient server. You will need to either wait for the recipient server to release the rate limit automatically, or contact them via alternate methods to request the limit be removed.
If your cPanel server is rate-limiting a sender that you wish to whitelist, you can do so following these steps:
- Log in to WHM as
root - Navigate to Home / Service Configuration / Exim Configuration Manager
- Click the Basic Editor tab
- Add the sender's IP to the Only-verify-recipient text field
- Click the Save button at the bottom of the page
The sender's mail server IP address can be manually whitelisted by adding it to the file /etc/trustedmailhosts. For example, the following would add IP 203.0.113.2:
# echo "203.0.113.2" >> /etc/trustedmailhosts
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