Symptoms
After installing Dovecot Solr FTS, you find that it is not running, and the webmail interface errors when searching.
Cause
The version of Java that is installed and in use is older than what Solr requires.
Resolution
- Access your server as the root via SSH, or access your WHM server and navigate to Terminal.
Run the following:
# update-alternatives --config java
You will be prompted to select the Java version installed. Enter 2 to select Java 11.
CONFIG_TEXT: There are 2 programs which provide 'java'.
Selection Command
-----------------------------------------------
*+ 1 java-1.8.0-openjdk.x86_64 (/usr/lib/jvm/java-1.8.0-openjdk-1.8.0.422.b05-1.el7_9.tuxcare.els1.x86_64/jre/bin/java)
2 java-11-openjdk.x86_64 (/usr/lib/jvm/java-11-openjdk-11.0.23.0.9-2.el7_9.x86_64/bin/java)
Enter to keep the current selection[+], or type selection number: 2With the correct Java version in use, Solr will need to be reinstalled. Remove Solr:
# /scripts/uninstall_dovecot_fts
Move aside the Solr data directory:
# mv /home/cpanelsolr{,.backup.broken}
Reinstall Solr:
# /scripts/install_dovecot_fts
Confirm the service was able to start:
# /scripts/restartsrv_cpanel_dovecot_solr --status
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