Symptoms
The Exim mail queue is building, and mail is not leaving the server with the following error or similar:
CONFIG_TEXT: Cannot assign requested address
Cause
The issue comes from an IP(s) listed within /etc/mailips that's not bound to the server.
Resolution
The /etc/mailips file needs to be corrected with an existing IP, or the customization needs to be disabled.
- Log in to the server via SSH or WHM's Terminal as the
rootuser. Open /etc/mailips in your preferred text editor, such as:
# nano /etc/mailips
Ensure the IP(s) provided within the file exist on the server. The proper format of /etc/mailips looks like:
# cat /etc/mailips
example.com: 203.0.113.3
sub.example.com: 203.0.113.4
example.net: 203.0.113.5
addon.example.net: 203.0.113.6
*: 203.0.113.2- Save the file.
/etc/mailips customization- Log in to WHM as
root. - Navigate to Home / Service Configuration / Exim Configuration Manager.
- Set Reference /etc/mailips for custom IP on outgoing SMTP connections to Off.
- Click the Save button at the bottom.
Once you have corrected /etc/mailips or disabled its customization, you can then start an email queue run:
- Log in to the server via SSH or WHM's Terminal as the
rootuser. Run the command:
# exim -qf &
Comments
0 comments
Article is closed for comments.