Symptoms
Emails sent to your server may be rejected as junk mail due to an “open resolver” error triggered by the zen.spamhaus.org RBL. When this happens, you’ll see error messages similar to the following in your Exim main_log file.
CONFIG_TEXT: JunkMail rejected - remote.mailserver.tld [203.0.113.2]:38564 is in an RBL: Error: open resolver; https://www.spamhaus.org/returnc/pub/203.0.113.2
Cause
Enabling the RBL: zen.spamhaus.org option in Home / Service Configuration / Exim Exim Configuration Manager requires using a non-public DNS resolver. Public resolvers such as Google, OpenDNS, CloudFlare, etc. will not return the correct results due to being rate-limited or blocked.
Resolution
Any public resolvers in /etc/resolv.conf will have to be removed and replaced with private resolvers.
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