Symptoms
A user is unable to load their inbox in Roundcube and messages similar to the following may be found in /var/log/maillog:
CONFIG_TEXT: Apr 24 20:08:50 server dovecot[3670167]: imap(user@domain.tld)<3693787><A3EA5hj6XJd/AAAB>: Error: Mailbox INBOX: mmap(size=433701832) failed with file /home/cpuser/mail/domain.tld/user/dovecot.index.cache: Cannot allocate memory
Cause
This issue occurs when the Dovecot index file is larger than Dovecot's Process Memory Limit. Increasing this limit will allow the inbox to load.
Resolution
- Log in to WHM as
root - Navigate to Home / Service Configuration / Mailserver Configuration
In the Process Memory Limit for Mail (MB) textbox, enter a value greater than the mmap size seen in the maillog error
Note: The mmap size is in bytes
- Click the Save Changes button at the bottom of the page
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