Symptoms:
Attempting to verify the license fails with this error:
# /usr/local/cpanel/cpkeyclt --force
CONFIG_TEXT: /usr/local/cpanel/cpkeyclt: error while loading shared libraries: /usr/local/cpanel/3rdparty/perl/530/lib/perl5/cpanel_lib/x86_64-linux-64int/auto/DNS/Unbound/Unbound.so: cannot open shared object file: No such file or directory
Cause:
The missing shared library file above is part of this package:
# rpm -qf /usr/local/cpanel/3rdparty/perl/530/lib/perl5/cpanel_lib/x86_64-linux-64int/auto/DNS/Unbound/Unbound.so
CONFIG_TEXT: cpanel-perl-530-DNS-Unbound-0.20-1.cp1186.x86_64
There are quite a few situations where that package might accidentally be erased from the server. One such occasion is where another package that has cpanel-perl-530-DNS-Unbound as a dependency gets uninstalled. For instance, uninstalling either of these two packages would also uninstall it:
CONFIG_TEXT: cpanel-unbound
CONFIG_TEXT: openssl
Resolution:
Running the following script should resolve this issue:
# /scripts/check_cpanel_rpms
Comments
0 comments
Article is closed for comments.