Symptoms
Roundcube gives an "Internal Server Error" pop-up notification after logging in successfully. You will find the following errors in the Dovecot maillog, indicating permissions problems with the Dovecot index files:
CONFIG_TEXT: Jan 01 00:00:00 server dovecot[#pid]: imap(user@email.tld)<1676052><mailID>: Error: Index is read-only, can't write-lock /home/username/mail/email.tld/user/dovecot.list.index.log
Cause
This is caused by incorrect ownership of Dovecot index data. The index files are owned by root:
[root@server /home/username/mail]cPs# stat ./email.tld/user/dovecot.list.index
File: ./email.tld/username/dovecot.list.index
Size: 968 Blocks: 8 IO Block: 4096 regular file
Device: fd04h/64772d Inode: 25337884943 Links: 1
Access: (0644/-rw-r--r--) Uid: ( 0/ root) Gid: ( 0/ root)
Access: 2026-01-11 22:26:01.576964569 +0800
Modify: 2026-01-11 22:26:01.578964693 +0800
Change: 2026-01-11 22:26:01.578964693 +0800
Birth: 2026-01-11 22:26:01.576964569 +0800
Resolution
Set the data to be owned by the user.
How to change ownership of a file or directory
Afterward, run the mailperm script to check for any other issues.
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