Symptoms
With the "Auto Expunge Spam" option enabled in WHM / Mailserver Configuration, RoundCube shows all emails accounts as having "0" disk usage. Other tools such as cPanel or the doveadm command still shows the correct disk usage.
Cause
RoundCube uses the IMAP GETQUOTAROOT command to get the quota information from Dovecot, which in turn retrieves it from the maildirsize file generated for each account. With the "Auto Expunge Spam" option enabled, the GETQUOTAROOT command does not read the maildirsize file and thus returns that the usage is 0.
We've opened an internal case for our development team to investigate this further. For reference, the case number is CPANEL-51300.
Resolution
To disable the Auto Expunge Spam feature. follow the step below.
- Log into WHM as the
rootuser. - Navigate to Home / Service Configuration / Mailserver Configuration.
- Scroll down to Auto Expunge Spam.
- Disable the Auto Expunge Spam option.
- Click the Save Changes button.
Note: This also occurs when the "Auto Expunge Trash" feature is enabled as well. More information on this can be found here:
v132: Roundcube disk usage displays 0% used
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