Symptoms
The message_linelength_limit setting has been raised in WHM, but messages are still rejected with the "Message has lines too long for transport" error with Exim 4.95.
Cause
The message_linelength_limit default limit has been increased in an update and the setting has been added in WHM to adjust it. This is stored within cPanel's standard DKIM and non-DKIM routers in the main exim.conf. Smarthosts and custom routers will bypass the options set by cPanel and thus ignore the value in WHM.
Resolution
Add a message_linelength_limit line to your "@TRANSPORTSTART@" entry for your Smarthost within "WHM / Exim Configuration Manager / Advanced Configuration Manager."
For example, you would add the final line to the TRANSPORTSTART configuration:
CONFIG_TEXT: @TRANSPORTSTART@
smtp:
driver = smtp
port = 587
hosts_require_auth = *
hosts_require_tls = *
message_linelength_limit = 2048
Note: Most Smarthost configurations have multiple transport configurations, such as one for DKIM and one without DKIM. Please be sure to check that each transport is updated to include a value for message_linelength_limit.
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