Symptoms
You may see a message similar to the following in the Exim log of the recipient mail server:
2020-11-22 12:34:01 SMTP data timeout (message abandoned) on connection from server.hostname.tld [xxx.xxx.xxx.xxx]:42678 F=<sender@domain.tld>
Description
The exim Documentation on Github provides some insight into this issue:
It means that there was a timeout while Exim was reading the contents of a message on an incoming SMTP connection. That is, it had successfully accepted a MAIL command, one or more RCPT commands, and a DATA command, and was in the process of reading the data itself. The length of timeout is controlled by the smtp_receive_timeout
option.
If you get this error regularly, the cause may be incorrect handling of large packets by a router or firewall. The maximum size of a packet is restricted on some links; routers should split packets that are larger.
There is a feature called path MTU discovery
that enables a sender to discover the maximum packet size over an entire path (multiple Internet links). This can be broken by misconfigured firewalls and routers. There is a good explanation at \?http://www.netheaven.com/pmtu.html? . Reducing the MTU on your local network can sometimes work round this problem. See Q0017 (3) for further discussion.
Common Causes
The following sections point out some common causes of this issue.
MTU Configuration Problems
The MTU configuration of the computers involved in the connection may not be set properly.
The correct configuration needs to be determined by a network administrator with the skills, training, and expertise required to do so for you. Although 1500 is a common MTU setting that you may try.
Firewall and Router Packet Handling
The firewall and router configuration of your network may need to be adjusted to handle packets properly. The details about how this would need to be changed are very specific to your network's situation so you'll need to reach out to a network administrator to review the situation.
IMPORTANT: Please keep in mind that there may be (and likely are) firewalls on your network outside of your own server that you may not be aware of. Just because your server's firewall is configured properly does not mean that the issue is not caused by a firewall. You must contact the network administrator of your hosting provider, data center, or network provider for details on other potential firewalls.
SMTP Timeout Configuration
The smtp_receive_timeout Exim configuration may have been modified from the default. You can check this and restore it to the default in WHM via Home » Service Configuration » Exim Configuration Manager » Advanced Editor
The cPanel default value is: 165s
You should use the cPanel default unless you have consulted with a network administrator that has provided adequate proof or explanation about why you need to deviate from the default.
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