Symptoms
dnsadmin is down and will not start. The following or something similar is logged to /usr/local/cpanel/logs/dnsadmin_log:
CONFIG_TEXT: Attempt to call undefined unimport method with arguments ("experimental::signatures") via package "warnings" (Perhaps you forgot to load the package?) at /usr/local/cpanel/Cpanel/Rand/Get.pm line 15.
Undefined subroutine &warnings::register_categories called at /usr/local/cpanel/3rdparty/perl/542/lib/warnings/register.pm line 22.
BEGIN failed--compilation aborted at /usr/local/cpanel/3rdparty/perl/542/lib/constant.pm line 4.
Compilation failed in require at /usr/local/cpanel/Cpanel/Rand/Get.pm line 368.
BEGIN failed--compilation aborted at /usr/local/cpanel/Cpanel/Rand/Get.pm line 368.
Compilation failed in require at /usr/local/cpanel/Cpanel/ServiceAuth.pm line 91.
Cause
Unknown at this time.
We've opened an internal case for our development team to investigate this further. For reference, the case number is CPANEL-57182. Follow this article to receive an email notification when a solution is published in the product.
Resolution
- Log in to WHM as the
rootuser - Navigate to Home / Server Configuration / Tweak Settings
- Under Software / Dormant services, uncheck dnsadmin
- Click the Save button
- Log in to the server via SSH or WHM's Terminal as the
rootuser -
Restart dnsadmin:
# /scripts/restartsrv_dnsadmin
Note: You should be able to re-enable dormant mode for the dnsadmin service after verifying that it is running.
Comments
0 comments
Article is closed for comments.