Symptoms
You receive the following error when attempting to send a message in Roundcube.
CONFIG_TEXT: 550 This message was classified as SPAM and may not be delivered
Cause
When the server is configured to scan outgoing mail for spam, SpamAssassin will prevent you from sending emails if it gives the email a high score. The high score for legitimate emails could be due to the threshold score being set too low, a spam rule being weighted too high for your server, or the Bayesian filter being corrupt.
Resolution
Increasing the Scan outgoing messages for spam and reject based on defined Apache SpamAssassin™ score (Minimum: 0.1; Maximum: 99.9) value in the WHM / Service Configuration / Exim Configuration Manager will allow your server to send emails with higher spam scores. However, it is best to determine why legitimate emails are receiving high scores and address that issue. SpamAssassin doesn't log why it assigns a particular score to an outgoing message, so you will have to find them in the message headers or strace the spamd process while attempting to send the message to see the spam score breakdown.
Additional Resources
How to find SpamAssassin scan results
How to Adjust Spam Assassin Rule Scoring Serverwide
How to reset cpaneleximscanner bayes database
How to disable Spam Assassin's bayes filter
Basic guide for using strace to diagnose software problems on Linux
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