Symptoms
You may find that emails sent via smarthost are not DKIM-signed despite having a valid DKIM record.
Cause
This typically occurs when the smarthost is not configured to send emails with DKIM.
Resolution
- Log in to the server via SSH or WHM's Terminal as the
rootuser - Open
/etc/exim.conf.localusing your preferred command-line text editor -
In your smarthost configuration, search for the following line:
CONFIG_TEXT: transport = remote_smtp
-
Change this to the following:
CONFIG_TEXT: transport = dkim_remote_smtp
- Save and close the file
-
Run the following scripts to load the change:
# /scripts/buildeximconf
# /scripts/restartsrv_exim
Email should now be DKIM-signed when using the smarthost.
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