Symptoms
When accessing Email Deliverability in WHM or cPanel to manage a domain, the following is seen with "timeout!".
CONFIG_TEXT: The system failed to complete validation of “yourdomain.com”’s “DKIM” because of an error: (XID mctmch) DNS query (default._domainkey.yourdomain.com/TXT) timeout!
Similar for SPF as well.
CONFIG_TEXT: The system failed to complete validation of “yourdomain.com”’s “SPF” because of an error: (XID uys7kv) DNS query (yourdomain.com/TXT) timeout!
Cause
The error happens when cPanel cannot query the domain's authoritative name servers configured at the registrar. This often occurs because of firewall rules blocking DNS connections or misconfigured nameservers.
Resolution
Most commonly, you will need to review multiple items to identify and resolve the issue. This involves verifying the firewall is allowing DNS connections and also verifying that the nameservers are defined correctly for your domain experiencing the issue.
Review and verify that the domain nameservers are reporting correctly using the following command.
CONFIG_TEXT: dig +trace NS yourdomain.com +short
The output should be returned without error. If an error occurs, please check the firewall settings and ensure the nameservers are configured correctly.
cPanel will check the authoritative nameservers for DNS records. If the connection times out or returns an error, ensuring the Firewall allows TCP and UDP outbound connections on port 53 to resolve this problem.
More information on the ports used by cPanel can be found on the page below.
In the DNS Zone Manager, verify if the correct nameservers are defined. Having the incorrect nameservers defined in cPanel when the server is the authoritative nameserver causes DNS queries to fail. You can verify if the nameservers are defined correctly and correct them either the WHM or the cPanel interface.
Comments
0 comments
Article is closed for comments.