Symptoms
Autoresponders are not triggering on certain email accounts, and no errors are logged.
Cause
Mail filters are processed before the autoresponder configured for an account to prevent filtered email from triggering the autoresponder. Certain rules in an email filter can force delivery for the message and end the mail transaction, which will cause mail to be delivered without processing the account's autoresponder.
Resolution
Review the filters on the address, and remove any that may be changing mail delivery behavior.
- Access the account directly through Webmail, or through the Email Accounts page in cPanel
- Access the Email Filters for the account
Remove any filters that may interrupt mail delivery. An example of such a filter may include directives like the following:
CONFIG_TEXT: save "$home/mail/domain.tld/mailuser/" 660
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