Symptoms
When entering a search in Roundcube Webmail, an error appears at the bottom right of the screen indicating that an error occurred.
# Internal Server Error
The maillog file returns an error about the FTS.
Maillog file is located at path:
/var/log/maillogCONFIG_TEXT: Error: fts_solr: Lookup failed: 500 Server Error
The Dovecot Solr log returns an error about needing a reindex.
Solr log is located at path:
/home/cpanelsolr/server/logs/solr.logCONFIG_TEXT: o.a.s.s.HttpSolrCall 500 Exception => java.lang.Illega lStateException: unexpected docvalues type NONE for field 'uid' (expected=NUMERIC). Re-index with correct docvalues type. at org.apache.lucene.index.DocValues.checkField(DocValues.java:218)
Cause
cPanel recently upgraded Dovecot Solr from version 8 to 9. The version change includes a schema change to some values. Due to the schema change, the field 'uid' values are returned as 'NONE'. Dovecot Solr recommends rebuilding the index during a version change, as the schema could've changed.
We've opened an internal case for our development team to investigate this further. For reference, the case number is CPANEL-48198. Follow this article to receive an email notification when a solution is published in the product.
Resolution
Rebuild the index as the issue will affect multiple users.
# /usr/local/cpanel/3rdparty/scripts/cpanel_dovecot_solr_rebuild_index
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