Symptoms
An email account's disk usage is higher than what is actually used, unrelated to mail compression and hard links. The email account also has a mailbox under it with an INBOX prefix, and the command below lists both an INBOX and a INBOX.INBOX:
# doveadm mailbox list -u "username@domain.tld"
An example of the commands output with a test account is below:
# doveadm mailbox list -u test@cptest.tld
INBOX # < Normal "Inbox"
INBOX.Archive
INBOX.Inbox # < Copy of INBOX adding to disk usage
INBOX.Inbox.test_inbox
INBOX.spam
INBOX.Trash
INBOX.Sent
INBOX.Junk
INBOX.Drafts
Cause
When mailboxes are created with the "INBOX." prefix, in the above example this would be the creation of the mailbox "Inbox.test_inbox" this causes a "INBOX.INBOX" mailbox to be created which then also tracks the disk usage for the default INBOX. Because the INBOX is counted twice, the email account reports more usage than it actually has.
We've opened an internal case for our development team to investigate this further. For reference, the case number is CPANEL-52586. Follow this article to receive an email notification when a solution is published in the product.
Resolution
Rename the duplicate mailbox folder:
doveadm mailbox rename -u $username@domain.tld "INBOX.INBOX.OldMailbox" "NewMailbox"
Note: You will need to replace "username@domain.tld" with the email address of the affected email account, and "Old Folder" and "New Folder" will need to be replaced with the folder that you're attempting to rename, and the new folder name.
2. Recalculate the user's quota.
doveadm quota recalc -u "$username@domain.tld"
Comments
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Update: CPANEL-51255 is solved in the following cPanel & WHM version(s) and newer:
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